aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sphyrna/sphyrna-python_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sphyrna/sphyrna-python_svn.bb')
-rw-r--r--recipes/sphyrna/sphyrna-python_svn.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/sphyrna/sphyrna-python_svn.bb b/recipes/sphyrna/sphyrna-python_svn.bb
new file mode 100644
index 0000000000..011c496fe4
--- /dev/null
+++ b/recipes/sphyrna/sphyrna-python_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Sphyrna - Hammerhead Reverse Engineering"
+HOMEPAGE = "http://projects.linuxtogo.org/projects/sphyrna"
+LICENSE = "GPLv2"
+DEPENDS = "readline"
+PV = "0.0+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://projects.linuxtogo.org/svn;module=sphyrna"
+
+S = "${WORKDIR}/sphyrna"
+
+inherit autotools
+
+PACKAGES = "${PN}-dbg sphyrna-console sphyrna-python"
+
+FILES_sphyrna-console = "${bindir}/hhconsole"
+FILES_sphyrna-python = "${bindir}/decode.py ${libdir}/python*/site-packages/sphyrna/*"
+
+PACKAGE_ARCH_sphyrna-python = "all"
+RDEPENDS_sphyrna-python = "python-core python-re"