summaryrefslogtreecommitdiffstats
path: root/recipes/squashfs-tools/squashfs-tools_2.2r2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/squashfs-tools/squashfs-tools_2.2r2.bb')
-rw-r--r--recipes/squashfs-tools/squashfs-tools_2.2r2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools_2.2r2.bb b/recipes/squashfs-tools/squashfs-tools_2.2r2.bb
new file mode 100644
index 0000000000..af1cc17e4f
--- /dev/null
+++ b/recipes/squashfs-tools/squashfs-tools_2.2r2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
+DEPENDS = "lzma"
+SECTION = "base"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
+ file://Makefile-2.2.patch;patch=1 \
+ file://squashfs2.0-tools-lzma.patch;patch=1"
+S = "${WORKDIR}/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}/squashfs-tools"
+
+prefix = ""
+
+do_compile() {
+ oe_runmake mksquashfs mksquashfs-lzma
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 mksquashfs ${D}${sbindir}/
+ install -m 0755 mksquashfs-lzma ${D}${sbindir}/
+}