aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squid/squid-3.1.7/fix-runs-in-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/squid/squid-3.1.7/fix-runs-in-configure.patch')
-rw-r--r--recipes/squid/squid-3.1.7/fix-runs-in-configure.patch80
1 files changed, 80 insertions, 0 deletions
diff --git a/recipes/squid/squid-3.1.7/fix-runs-in-configure.patch b/recipes/squid/squid-3.1.7/fix-runs-in-configure.patch
new file mode 100644
index 0000000000..3ae771f3f5
--- /dev/null
+++ b/recipes/squid/squid-3.1.7/fix-runs-in-configure.patch
@@ -0,0 +1,80 @@
+Index: squid-3.1.6/configure.in
+===================================================================
+--- squid-3.1.6.orig/configure.in 2010-08-19 23:19:52.000000000 +0400
++++ squid-3.1.6/configure.in 2010-08-19 23:22:44.000000000 +0400
+@@ -364,10 +364,6 @@
+ fi
+ ])
+
+-dnl Nasty hack to get autoconf 2.64 on Linux to run.
+-dnl all other uses of RUN_IFELSE are wrapped inside CACHE_CHECK which breaks on 2.64
+-AC_RUN_IFELSE([AC_LANG_SOURCE([[ int main(int argc, char **argv) { return 0; } ]])],[],[],[])
+-
+ dnl This is a developer only option.. developers know how to set defines
+ dnl
+ dnl AC_ARG_ENABLE(xmalloc-debug,
+@@ -1318,7 +1314,7 @@
+ dnl Verify that epoll really works
+ if test $ac_cv_func_epoll_ctl = yes; then
+ AC_CACHE_CHECK(if epoll works, ac_cv_epoll_works,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <sys/epoll.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+@@ -3070,7 +3066,7 @@
+ dnl setresuid() but doesn't implement it.
+ dnl
+ AC_CACHE_CHECK(if setresuid is implemented, ac_cv_func_setresuid,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdlib.h>
+ int main(int argc, char **argv) {
+ if(setresuid(-1,-1,-1)) {
+@@ -3090,7 +3086,7 @@
+ dnl copy that crashes with a buffer over-run!
+ dnl
+ AC_CACHE_CHECK(if strnstr is well implemented, ac_cv_func_strnstr,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -3116,7 +3112,7 @@
+ dnl Test for va_copy
+ dnl
+ AC_CACHE_CHECK(if va_copy is implemented, ac_cv_func_va_copy,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdarg.h>
+ #include <stdlib.h>
+ int f (int i, ...) {
+@@ -3139,7 +3135,7 @@
+ dnl Some systems support __va_copy
+ dnl
+ AC_CACHE_CHECK(if __va_copy is implemented, ac_cv_func___va_copy,
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include <stdarg.h>
+ #include <stdlib.h>
+ int f (int i, ...) {
+Index: squid-3.1.6/helpers/negotiate_auth/squid_kerb_auth/configure.in
+===================================================================
+--- squid-3.1.6.orig/helpers/negotiate_auth/squid_kerb_auth/configure.in 2010-08-01 18:01:38.000000000 +0400
++++ squid-3.1.6/helpers/negotiate_auth/squid_kerb_auth/configure.in 2010-08-19 23:20:34.000000000 +0400
+@@ -367,13 +367,13 @@
+
+ CPPFLAGS="$CPPFLAGS -I../../../ -I../../../include/ -I$squid_dir/include -I$squid_dir/src -I$squid_dir"
+ AC_CACHE_CHECK([for SQUID at '$squid_dir' ],ac_cv_have_squid,[
+-AC_TRY_RUN([
++AC_TRY_COMPILE([
+ #include <config.h>
+ int main(int argc, char *argv[]) {
+ #ifdef SQUID_CONFIG_H
+ return 0;
+ #else
+-return 1;
++boom!
+ #endif
+ }],
+ ac_cv_have_squid=yes,