aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/subversion/subversion_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/subversion/subversion_1.3.1.bb')
-rw-r--r--recipes/subversion/subversion_1.3.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/subversion/subversion_1.3.1.bb b/recipes/subversion/subversion_1.3.1.bb
new file mode 100644
index 0000000000..79e5e67d7b
--- /dev/null
+++ b/recipes/subversion/subversion_1.3.1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util-0.9.12 neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+PR = "r1"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://apr-regex.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}