aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/swfdec/swfdec-mozilla_0.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/swfdec/swfdec-mozilla_0.7.4.bb')
-rw-r--r--recipes/swfdec/swfdec-mozilla_0.7.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/swfdec/swfdec-mozilla_0.7.4.bb b/recipes/swfdec/swfdec-mozilla_0.7.4.bb
new file mode 100644
index 0000000000..ed727555f7
--- /dev/null
+++ b/recipes/swfdec/swfdec-mozilla_0.7.4.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Swfdec plugin for browsers using NPAPI. Swfdec is a decoder/renderer for Macromedia Flash animations."
+LICENSE = "LGPL"
+
+PR = "r1"
+
+DEPENDS = "gst-ffmpeg swfdec gstreamer libsoup-2.4 pango cairo liboil zlib gtk+ alsa-lib \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+RDEPENDS = "gst-ffmpeg"
+
+SRC_URI = "http://swfdec.freedesktop.org/download/swfdec-mozilla/0.7/${P}.tar.gz \
+"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/mozilla/plugins/*.so"
+FILES_${PN}-dev += "${libdir}/mozilla/plugins/*a"
+FILES_${PN}-dbg += "${libdir}/mozilla/plugins/.debug"
+