aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/swfdec/swfdec_0.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/swfdec/swfdec_0.7.2.bb')
-rw-r--r--recipes/swfdec/swfdec_0.7.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/swfdec/swfdec_0.7.2.bb b/recipes/swfdec/swfdec_0.7.2.bb
new file mode 100644
index 0000000000..7e3c15dd6c
--- /dev/null
+++ b/recipes/swfdec/swfdec_0.7.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Swfdec is a decoder/renderer for Macromedia Flash animations."
+LICENSE = "LGPL"
+
+DEPENDS = "gstreamer libsoup-2.4 pango cairo liboil zlib gtk+ alsa-lib \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+PR = "r1"
+
+SRC_URI = "http://swfdec.freedesktop.org/download/swfdec/0.7/${P}.tar.gz \
+"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/player/.libs/swfplay ${D}/${bindir}
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libswfdecgtk libswfdec"
+
+FILES_${PN} += "${datadir}/icons"
+FILES_libswfdec = "${libdir}/libswfdec-0.7.so.*"
+FILES_libswfdecgtk = "${libdir}/libswfdec-gtk-0.7.so*"
+
+