aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/system-config-printer/system-config-printer_1.1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/system-config-printer/system-config-printer_1.1.7.bb')
-rw-r--r--recipes/system-config-printer/system-config-printer_1.1.7.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/system-config-printer/system-config-printer_1.1.7.bb b/recipes/system-config-printer/system-config-printer_1.1.7.bb
new file mode 100644
index 0000000000..5a6d6320ac
--- /dev/null
+++ b/recipes/system-config-printer/system-config-printer_1.1.7.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "cups Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "cups"
+RDEPENDS_python-cupshelpers += "python-pprint python-netclient python-misc"
+PR = "r2"
+
+SRC_URI = "http://cyberelk.net/tim/data/${PN}/1.1/${PN}-${PV}.tar.bz2"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ # disable xmlto usage since we won't use manpages
+ sed -i 's,xmlto,echo xmlto,g' ${S}/Makefile*
+}
+
+PACKAGES += "python-cupshelpers"
+
+FILES_${PN} = "" # we're not going to support it for now
+FILES_python-cupshelpers = "${libdir}"