aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/telepathy/telepathy-gabble_0.7.27.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/telepathy/telepathy-gabble_0.7.27.bb')
-rw-r--r--recipes/telepathy/telepathy-gabble_0.7.27.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/telepathy/telepathy-gabble_0.7.27.bb b/recipes/telepathy/telepathy-gabble_0.7.27.bb
new file mode 100644
index 0000000000..ce16509800
--- /dev/null
+++ b/recipes/telepathy/telepathy-gabble_0.7.27.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gabble: a Jabber/XMPP connection manager"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus loudmouth telepathy-glib"
+LICENSE = "LGPL"
+
+# gabble.manager needs to get regenerated every release, so please don't copy it over blindly
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-gabble/${P}.tar.gz \
+ file://gabble.manager"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/gabble.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"