aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/temper/temper_0.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/temper/temper_0.0.1.bb')
-rw-r--r--recipes/temper/temper_0.0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/temper/temper_0.0.1.bb b/recipes/temper/temper_0.0.1.bb
new file mode 100644
index 0000000000..2d6679dc9b
--- /dev/null
+++ b/recipes/temper/temper_0.0.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A fan control script for the Thecus n1200 or n2100"
+SECTION = "console/network"
+PR = "r1"
+LICENSE = "GPL"
+COMPATIBLE_MACHINE = "(n1200|n2100)"
+RDEPENDS = "hddtemp"
+
+SRC_URI = "file://temper \
+ file://init"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "temper"
+INITSCRIPT_PARAMS = "defaults"
+
+do_install() {
+ install -D -m 0755 ${WORKDIR}/temper ${D}/usr/sbin/temper
+ install -D -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/temper
+}