aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/totem/totem_1.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/totem/totem_1.0.4.bb')
-rw-r--r--recipes/totem/totem_1.0.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/totem/totem_1.0.4.bb b/recipes/totem/totem_1.0.4.bb
new file mode 100644
index 0000000000..a12f307ffa
--- /dev/null
+++ b/recipes/totem/totem_1.0.4.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.gnome.org/projects/totem/"
+LICENSE="GPL"
+
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/totem/1.0/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1 \
+ file://nonautilus.patch;patch=1 \
+ file://intl.patch;patch=1 \
+ file://cflags.patch;patch=1 \
+ file://gtkonly.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libxml2"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}