aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-env.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot/u-boot-env.bb')
-rw-r--r--recipes/u-boot/u-boot-env.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-env.bb b/recipes/u-boot/u-boot-env.bb
new file mode 100644
index 0000000000..1bee272d82
--- /dev/null
+++ b/recipes/u-boot/u-boot-env.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Dummy package to get uboot env image into deploy"
+
+PR = "r1"
+
+inherit kernel-arch
+
+SRC_URI = "file://default-env.ascr"
+
+
+do_compile() {
+ cp ${WORKDIR}/default-env.ascr ${S}
+ uboot-mkimage -A ${UBOOT_ARCH} -O linux -T script -C none -a 0 -e 0 -n "${DISTRO_NAME}/${MACHINE} env script" -d default-env.ascr default_env.img
+}
+
+do_stage() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 ${S}/default_env.img ${DEPLOY_DIR_IMAGE}/
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/default_env.img
+
+}
+
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"