summaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-mkimage-1.3.2/fix-arm920t-eabi.patch (renamed from recipes/u-boot/u-boot-mkimage-native-1.3.2/fix-arm920t-eabi.patch)0
-rw-r--r--recipes/u-boot/u-boot-mkimage_1.3.2.bb (renamed from recipes/u-boot/u-boot-mkimage-native_1.3.2.bb)18
2 files changed, 11 insertions, 7 deletions
diff --git a/recipes/u-boot/u-boot-mkimage-native-1.3.2/fix-arm920t-eabi.patch b/recipes/u-boot/u-boot-mkimage-1.3.2/fix-arm920t-eabi.patch
index 69cb75891d..69cb75891d 100644
--- a/recipes/u-boot/u-boot-mkimage-native-1.3.2/fix-arm920t-eabi.patch
+++ b/recipes/u-boot/u-boot-mkimage-1.3.2/fix-arm920t-eabi.patch
diff --git a/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb b/recipes/u-boot/u-boot-mkimage_1.3.2.bb
index cf135a5231..53240b35a1 100644
--- a/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb
+++ b/recipes/u-boot/u-boot-mkimage_1.3.2.bb
@@ -5,21 +5,25 @@ SECTION = "bootloader"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://fix-arm920t-eabi.patch;patch=1"
-S = "${WORKDIR}/u-boot-${PV}"
+PR = "r1"
-inherit native
+S = "${WORKDIR}/u-boot-${PV}"
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
do_compile () {
- oe_runmake smdk2410_config
- oe_runmake tools STRIP='/bin/true'
+ oe_runmake smdk2410_config
+ oe_runmake tools STRIP='/bin/true'
}
-do_stage () {
- install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
- ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
}
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
+
SRC_URI[md5sum] = "78b1c2722d3907b5fae2cd219dbaf927"
SRC_URI[sha256sum] = "8ab07cd758a1775642629e624f70e376fa8e84a2f879dee4544158d9c90cde2a"