aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u2nl/files/buildsystem.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u2nl/files/buildsystem.patch')
-rw-r--r--recipes/u2nl/files/buildsystem.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/u2nl/files/buildsystem.patch b/recipes/u2nl/files/buildsystem.patch
new file mode 100644
index 0000000000..9de58fa435
--- /dev/null
+++ b/recipes/u2nl/files/buildsystem.patch
@@ -0,0 +1,32 @@
+Index: u2nl-1.3/Makefile
+===================================================================
+--- u2nl-1.3.orig/Makefile 2005-01-03 19:31:20.000000000 +0100
++++ u2nl-1.3/Makefile 2006-12-14 12:38:15.052227000 +0100
+@@ -1,5 +1,25 @@
++CC = gcc
++CFLAGS = -Wall -g
++LDFLAGS =
++
++DESTDIR =
++prefix = /usr/local
++bindir = $(prefix)/bin
++
++INSTALL_BIN = install -m 0755
++INSTALL_DIR = install -d
++
+ all: u2nl
+
+ u2nl: u2nl.c
+- gcc -Wall -g u2nl.c -o u2nl
+-
++ $(CC) $(CFLAGS) $(LDFLAGS) u2nl.c -o u2nl
++
++install:
++ $(INSTALL_DIR) $(DESTDIR)$(bindir)
++ $(INSTALL_BIN) u2nl $(DESTDIR)$(bindir)/u2nl
++
++uninstall:
++ -rm -f $(DESTDIR)$(bindir)/u2nl
++
++clean:
++ -rm -fR u2nl