summaryrefslogtreecommitdiffstats
path: root/recipes/u2nl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u2nl')
-rw-r--r--recipes/u2nl/files/buildsystem.patch32
-rw-r--r--recipes/u2nl/u2nl_1.3.bb15
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes/u2nl/files/buildsystem.patch b/recipes/u2nl/files/buildsystem.patch
new file mode 100644
index 0000000000..9de58fa435
--- /dev/null
+++ b/recipes/u2nl/files/buildsystem.patch
@@ -0,0 +1,32 @@
+Index: u2nl-1.3/Makefile
+===================================================================
+--- u2nl-1.3.orig/Makefile 2005-01-03 19:31:20.000000000 +0100
++++ u2nl-1.3/Makefile 2006-12-14 12:38:15.052227000 +0100
+@@ -1,5 +1,25 @@
++CC = gcc
++CFLAGS = -Wall -g
++LDFLAGS =
++
++DESTDIR =
++prefix = /usr/local
++bindir = $(prefix)/bin
++
++INSTALL_BIN = install -m 0755
++INSTALL_DIR = install -d
++
+ all: u2nl
+
+ u2nl: u2nl.c
+- gcc -Wall -g u2nl.c -o u2nl
+-
++ $(CC) $(CFLAGS) $(LDFLAGS) u2nl.c -o u2nl
++
++install:
++ $(INSTALL_DIR) $(DESTDIR)$(bindir)
++ $(INSTALL_BIN) u2nl $(DESTDIR)$(bindir)/u2nl
++
++uninstall:
++ -rm -f $(DESTDIR)$(bindir)/u2nl
++
++clean:
++ -rm -fR u2nl
diff --git a/recipes/u2nl/u2nl_1.3.bb b/recipes/u2nl/u2nl_1.3.bb
new file mode 100644
index 0000000000..7cfa7b75ba
--- /dev/null
+++ b/recipes/u2nl/u2nl_1.3.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "u2nl (pronounce: "u-tunnel", universal tunnel) is capable of \
+tunneling each and every TCP network connection from a Linux (2.4 and above, \
+with netfilter) computer through an http CONNECT proxy."
+HOMEPAGE = "http://www.reitwiessner.de/programs/u2nl.html"
+LICENSE = "GPL"
+SECTION = "console/network"
+PRIORITY = "optional"
+
+SRC_URI = "http://www.reitwiessner.de/programs/u2nl-${PV}.tar.gz \
+ file://buildsystem.patch;patch=1"
+S = "${WORKDIR}/u2nl-${PV}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}