aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udhcp/udhcp_0.9.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/udhcp/udhcp_0.9.8.bb')
-rw-r--r--recipes/udhcp/udhcp_0.9.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/udhcp/udhcp_0.9.8.bb b/recipes/udhcp/udhcp_0.9.8.bb
new file mode 100644
index 0000000000..40487efe84
--- /dev/null
+++ b/recipes/udhcp/udhcp_0.9.8.bb
@@ -0,0 +1,29 @@
+SECTION = "console/network"
+DESCRIPTION = "Small dhcp client and dhcp server. Designed for embedded use."
+HOMEPAGE = "http://udhcp.busybox.net/"
+LICENSE = "GPL"
+
+SRC_URI = "http://udhcp.busybox.net/source/udhcp-${PV}.tar.gz \
+ file://install.patch;patch=1 \
+ file://nostrip.patch;patch=1 \
+ file://gcc3.patch;patch=1"
+
+inherit autotools
+
+CFLAGS =+ "-UDEFAULT_SCRIPT -DDEFAULT_SCRIPT=\"${datadir}/udhcpc/default.script\" \
+ -DVERSION=\"${PV}\""
+EXTRA_OEMAKE = "'CC=${CC}' 'LD=${CCLD}' \
+ 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}' \
+ 'prefix=${prefix}' 'sbindir=/sbin' \
+ 'usrsbindir=${sbindir}' \
+ 'usrbindir=${bindir}' \
+ 'datadir=${datadir}'"
+
+PACKAGES = "${PN}-dbg udhcpc udhcpc-doc udhcpd udhcpd-doc ${PN}"
+FILES_udhcpc = "/sbin/udhcpc ${datadir}/udhcpc"
+FILES_udhcpc-doc = "${mandir}/man8/udhcpc.8"
+FILES_udhcpd = "${sbindir}/udhcpd \
+ ${bindir}/dumpleases"
+FILES_udhcpd-doc = "${mandir}/man1/dumpleases.1 \
+ ${mandir}/man8/udhcpd.8 \
+ ${mandir}/man5/udhcpd.conf.5"