aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb')
-rw-r--r--recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb b/recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb
new file mode 100644
index 0000000000..3919106a95
--- /dev/null
+++ b/recipes/usb-modeswitch/usb-modeswitch_1.0.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "A mode switching tool for controlling 'flip flop' (multiple device) USB gear"
+SECTION = "base"
+PRIORITY = "required"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libusb0"
+
+SRC_URI = "http://www.draisberghof.de/usb_modeswitch/usb_modeswitch-${PV}.tar.bz2"
+
+S = "${WORKDIR}/usb_modeswitch-${PV}"
+
+PACKAGES = "${PN}"
+FILES_${PN} = "${bindir} ${sysconfdir}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${sysconfdir}
+ install -m 0755 ${S}/usb_modeswitch ${D}${bindir}/usb_modeswitch
+ install -m 0644 ${S}/usb_modeswitch.conf ${D}${sysconfdir}/usb_modeswitch.conf
+}