summaryrefslogtreecommitdiffstats
path: root/recipes/usound
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/usound')
-rw-r--r--recipes/usound/usound_0.2.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/usound/usound_0.2.0.bb b/recipes/usound/usound_0.2.0.bb
new file mode 100644
index 0000000000..0ac4022e91
--- /dev/null
+++ b/recipes/usound/usound_0.2.0.bb
@@ -0,0 +1,26 @@
+LICENSE = "GPL"
+DESCRIPTION = "The Useful Sound Daemon"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "pth"
+
+SRC_URI = "http://mattcamp.paunix.org/usound/usound-${PV}.tar.gz"
+S = "${WORKDIR}/usound"
+
+do_compile() {
+ for dir in lib daemon
+ do
+ cd ${S}/$dir
+ oe_runmake
+ done
+}
+
+do_stage() {
+ oe_libinstall -a -C lib libusound ${STAGING_LIBDIR}
+ install -m 0644 lib/usound.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 daemon/usound ${D}${bindir}
+}