aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/v4l2apps
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/v4l2apps')
-rw-r--r--recipes/v4l2apps/libv4l_0.5.8.bb16
-rw-r--r--recipes/v4l2apps/v4l2apps-20020317/flags.patch16
-rw-r--r--recipes/v4l2apps/v4l2apps_20020317.bb17
3 files changed, 49 insertions, 0 deletions
diff --git a/recipes/v4l2apps/libv4l_0.5.8.bb b/recipes/v4l2apps/libv4l_0.5.8.bb
new file mode 100644
index 0000000000..a53c52f223
--- /dev/null
+++ b/recipes/v4l2apps/libv4l_0.5.8.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "libv4l is a collection of libraries which adds a thin abstraction layer on top of video4linux2 devices."
+LICENSE = "LGPLv2"
+
+SRC_URI = "http://people.atrpms.net/~hdegoede/libv4l-${PV}.tar.gz"
+
+inherit pkgconfig
+
+export PREFIX="${prefix}"
+
+do_install() {
+ oe_runmake DESTDIR="${D}" install
+}
+
+do_stage() {
+ oe_runmake DESTDIR="${STAGING_DIR_TARGET}" install
+}
diff --git a/recipes/v4l2apps/v4l2apps-20020317/flags.patch b/recipes/v4l2apps/v4l2apps-20020317/flags.patch
new file mode 100644
index 0000000000..d97c7102fe
--- /dev/null
+++ b/recipes/v4l2apps/v4l2apps-20020317/flags.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- v4l2apps-20020317-r0/Makefile~flags 2002-03-18 00:54:08.000000000 -0600
++++ v4l2apps-20020317-r0/Makefile 2004-06-02 16:06:50.000000000 -0500
+@@ -1,6 +1,7 @@
+ CC=gcc
+ CFLAGS=-Wall
+-LDLIBS=-L/usr/X11R6/lib -lXaw -lXt -lX11
++LDFLAGS=-L/usr/X11R6/lib
++LDLIBS=-lXaw -lXt -lX11
+ all: xcaptest vidpanel vcat vctrl testmp1e
+ xcaptest: xcaptest.c
+ vidpanel: vidpanel.c
diff --git a/recipes/v4l2apps/v4l2apps_20020317.bb b/recipes/v4l2apps/v4l2apps_20020317.bb
new file mode 100644
index 0000000000..9915cd63a0
--- /dev/null
+++ b/recipes/v4l2apps/v4l2apps_20020317.bb
@@ -0,0 +1,17 @@
+SECTION = "console/utils"
+DESCRIPTION = "Video4linux Two sample applications"
+LICENSE = "PD"
+DEPENDS = "libxaw virtual/libx11 libxt"
+
+SRC_URI = "http://www.thedirks.org/pub/v4l2/apps/apps${PV}.tgz"
+S = "${WORKDIR}"
+
+#FIXME: currently busted, as it requires v4l2 -kernel headers.
+#either fix the apps to use headers not in linux/, or make this package
+#depend on an actual virtual/kernel that supports v4l2.
+BROKEN = "1"
+
+do_install () {
+ install -d ${S}/${bindir}
+ install -m 0755 vcat vctrl vidpanel xcaptest ${D}${bindir}/
+}