aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vdr/files/disable_plugin.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vdr/files/disable_plugin.patch')
-rw-r--r--recipes/vdr/files/disable_plugin.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/vdr/files/disable_plugin.patch b/recipes/vdr/files/disable_plugin.patch
new file mode 100644
index 0000000000..80cf236a44
--- /dev/null
+++ b/recipes/vdr/files/disable_plugin.patch
@@ -0,0 +1,18 @@
+Index: vdr-1.7.10/Makefile
+===================================================================
+--- vdr-1.7.10.orig/Makefile 2010-01-03 18:19:12.915007986 +0100
++++ vdr-1.7.10/Makefile 2010-01-03 18:29:47.598277455 +0100
+@@ -142,11 +142,12 @@
+ noapiv="";\
+ for i in `ls $(PLUGINDIR)/src | grep -v '[^a-z0-9]'`; do\
+ echo "Plugin $$i:";\
+- if ! grep -q "\$$(LIBDIR)/.*\$$(APIVERSION)" "$(PLUGINDIR)/src/$$i/Makefile" ; then\
++ if ! grep -q "\$$(LIBDIR)/.*\$$(APIVERSION)" "$(PLUGINDIR)/src/$$i/Makefile"; then \
+ echo "ERROR: plugin $$i doesn't honor APIVERSION - not compiled!";\
+ noapiv="$$noapiv $$i";\
+ continue;\
+ fi;\
++ if [ "$$i" = "skincurses" ]; then echo; echo "*** $$i plugin disbabled "; echo; continue; fi;\
+ $(MAKE) -C "$(PLUGINDIR)/src/$$i" all || failed="$$failed $$i";\
+ done;\
+ if [ -n "$$noapiv" ] ; then echo; echo "*** plugins without APIVERSION:$$noapiv"; echo; fi;\