aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vim/vim_7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vim/vim_7.2.bb')
-rw-r--r--recipes/vim/vim_7.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/vim/vim_7.2.bb b/recipes/vim/vim_7.2.bb
new file mode 100644
index 0000000000..37bdfb8809
--- /dev/null
+++ b/recipes/vim/vim_7.2.bb
@@ -0,0 +1,27 @@
+VIMVER = "72"
+
+# vim-tiny sets that too
+VIMFEATURES ?= "big"
+
+# GUI type - gvim recipe sets "gtk2"
+VIMGUI ?= "none"
+
+# gvim recipes uses "--with-x"
+VIMX ?= "--without-x"
+
+require vim.inc
+
+PR = "${INC_PR}.0"
+
+# 001-394.diff contains 394 patches fetched from upstream
+SRC_URI += "file://001-394.diff"
+
+# we need to apply patches in other dir then ${S}
+do_applypatch() {
+ cd ${WORKDIR}/vim${VIMVER}
+ patch -p1 <${WORKDIR}/001-394.diff
+}
+
+addtask applypatch after do_unpack before do_patch
+
+RCONFLICTS_${PN} = "gvim vim-tiny"