aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vnc/fbvncserver-kmodule_0.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vnc/fbvncserver-kmodule_0.9.4.bb')
-rw-r--r--recipes/vnc/fbvncserver-kmodule_0.9.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/vnc/fbvncserver-kmodule_0.9.4.bb b/recipes/vnc/fbvncserver-kmodule_0.9.4.bb
new file mode 100644
index 0000000000..4abdb6c7b0
--- /dev/null
+++ b/recipes/vnc/fbvncserver-kmodule_0.9.4.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Framebuffer VNC server keyboard events module"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://sdgsystems.com/download/fbvncserver-${PV}.tar.gz \
+ file://libvncs0.6.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://kernelinclude.patch;patch=1 \
+ file://ipaq.patch;patch=1"
+
+S = "${WORKDIR}/fbvncserver-${PV}"
+
+inherit module
+
+FBVNCSERVER_SYSTEM = "zaurus"
+FBVNCSERVER_SYSTEM_h3600 = "ipaq"
+FBVNCSERVER_SYSTEM_h3900 = "ipaq"
+
+EXTRA_OEMAKE = "KERNEL_INCLUDES=-I${STAGING_KERNEL_DIR}/include ${FBVNCSERVER_SYSTEM}_kbdsim.o"
+
+do_install () {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/misc
+ install -m 0644 ${FBVNCSERVER_SYSTEM}_kbdsim.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/misc/kbdsim.o
+}