aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vnc/libvncserver_0.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vnc/libvncserver_0.9.1.bb')
-rw-r--r--recipes/vnc/libvncserver_0.9.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/vnc/libvncserver_0.9.1.bb b/recipes/vnc/libvncserver_0.9.1.bb
new file mode 100644
index 0000000000..488ed0d87f
--- /dev/null
+++ b/recipes/vnc/libvncserver_0.9.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "library for easy implementation of a RDP/VNC server"
+AUTHOR = "Johannes Schindelin <dscho@users.sourceforge.net"
+HOMEPAGE = "http://sourceforge.net/projects/libvncserver/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "zlib jpeg"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/LibVNCServer-${PV}.tar.gz \
+ file://configure_ac.patch;patch=1 \
+ file://clientlogger.patch;patch=1 \
+ file://autoreconf.patch;patch=1"
+S = "${WORKDIR}/LibVNCServer-${PV}"
+
+# => create libvncserver only
+EXTRA_OEMAKE_append=" SUBDIRS='libvncserver' "
+
+inherit autotools
+do_stage() {
+ autotools_stage_all
+}