aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vnc/tightvnc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vnc/tightvnc/Makefile')
-rw-r--r--recipes/vnc/tightvnc/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/vnc/tightvnc/Makefile b/recipes/vnc/tightvnc/Makefile
new file mode 100644
index 0000000000..16420423f2
--- /dev/null
+++ b/recipes/vnc/tightvnc/Makefile
@@ -0,0 +1,22 @@
+SOURCES = argsresources.c \
+caps.c \
+colour.c \
+cursor.c \
+desktop.c \
+dialogs.c \
+fullscreen.c \
+listen.c \
+misc.c \
+popup.c \
+rfbproto.c \
+selection.c \
+shm.c \
+sockets.c \
+tunnel.c \
+vncviewer.c \
+../libvncauth/vncauth.c \
+../libvncauth/d3des.c
+
+tightvncviewer : $(SOURCES)
+ $(CC) $(CFLAGS) $(LDFLAGS) -I. -I../include -I../libvncauth/ -lX11 -lXaw6 -ljpeg -lz -o tightvncviewer $(SOURCES)
+