aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vte/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vte/files')
-rw-r--r--recipes/vte/files/vte-pkgconfig-fixes.patch47
-rw-r--r--recipes/vte/files/vte.desktop.in76
2 files changed, 123 insertions, 0 deletions
diff --git a/recipes/vte/files/vte-pkgconfig-fixes.patch b/recipes/vte/files/vte-pkgconfig-fixes.patch
new file mode 100644
index 0000000000..2acc7348e7
--- /dev/null
+++ b/recipes/vte/files/vte-pkgconfig-fixes.patch
@@ -0,0 +1,47 @@
+Index: vte-0.16.9/configure.in
+===================================================================
+--- vte-0.16.9.orig/configure.in 2007-09-17 23:07:18.000000000 +0100
++++ vte-0.16.9/configure.in 2008-03-05 15:59:04.000000000 +0000
+@@ -381,8 +381,6 @@
+
+ # Search for the required modules.
+ PKG_CHECK_MODULES(VTE,[$wantedmodules])
+-NEEDEDPACKAGES="$wantedmodules"
+-AC_SUBST(NEEDEDPACKAGES)
+
+ # Check for various optional functions within those modules
+ save_CFLAGS="$CFLAGS"
+@@ -403,10 +401,12 @@
+
+ # Require Freetype2. First see if there is suitable pkgconfig file...
+ PKG_CHECK_EXISTS(freetype2 >= 6.1.0,
+- [PKG_CHECK_MODULES(FT2, freetype2)], [
++ [PKG_CHECK_MODULES(FT2, freetype2)
++ wantedmodules="$wantedmodules freetype2 >= 6.1.0"], [
+ # We use our local copy of the macro because packages of
+ # freetype's development files don't always include the proper macro.
+- VTE_CHECK_FT2(6.1.0,,
++ VTE_CHECK_FT2(6.1.0,[
++ wantedmodules="$wantedmodules freetype2 >= 6.1.0" ],
+ [AC_MSG_ERROR([You must have freetype 2.0.2 or later to build vte.])])])
+
+ # Temporarily pull in the Freetype cflags and libs for checking what's
+@@ -508,6 +508,8 @@
+ CFLAGS="$savecflags"
+ CPPFLAGS="$savecppflags"
+
++NEEDEDPACKAGES="$wantedmodules"
++AC_SUBST(NEEDEDPACKAGES)
+
+ wcs_funcs_includes="
+ #ifdef HAVE_STRING_H
+Index: vte-0.16.9/vte.pc.in
+===================================================================
+--- vte-0.16.9.orig/vte.pc.in 2007-02-26 21:05:19.000000000 +0000
++++ vte-0.16.9/vte.pc.in 2008-03-05 15:56:37.000000000 +0000
+@@ -11,4 +11,4 @@
+ Requires: @NEEDEDPACKAGES@
+ Libs: -L${libdir} -lvte @OTHERLIBS@
+ Libs.private: @FT2_LIBS@
+-Cflags: -I${includedir} @FT2_CFLAGS@ @OTHERCFLAGS@
++Cflags: -I${includedir} @OTHERCFLAGS@
diff --git a/recipes/vte/files/vte.desktop.in b/recipes/vte/files/vte.desktop.in
new file mode 100644
index 0000000000..ef2bf17efc
--- /dev/null
+++ b/recipes/vte/files/vte.desktop.in
@@ -0,0 +1,76 @@
+[Desktop Entry]
+TryExec=vte
+Exec=vte
+Icon=terminal
+Type=Application
+Categories=GTK;Utility;TerminalEmulator;GPE;
+StartupNotify=true
+Name=VTE Terminal
+Name[af]=Vte-terminaal
+Name[ar]=Vte Terminal
+Name[bg]=Vte терминал
+Name[ca]=Terminal del VTE
+Name[cs]=VTE terminál
+Name[da]=VTE terminal
+Name[de]=Vte-Terminal
+Name[el]=Τερματικό του Vte
+Name[es]=Terminal de Vte
+Name[et]=VTE terminal
+Name[fi]=Vte-pääteohjelma
+Name[fr]=Terminal Vte
+Name[gl]=Vte Terminal
+Name[hu]=Vte konzol
+Name[it]=Terminale Vte
+Name[ja]=Vte 端末
+Name[km]=ស្ថានីយ Vte
+Name[ko]=VTE 터미널
+Name[lt]=Vte terminalas
+Name[mr]=VTE टर्मिनल
+Name[nb]=Vte-terminal
+Name[nl]=Vte Terminal
+Name[pa]=VTE ਟਰਮੀਨਲ
+Name[pl]=Terminal Vte
+Name[pt]=Vte Terminal
+Name[pt_BR]=Terminal do Vte
+Name[ru]=Vte терминал
+Name[sk]=VTE Terminál
+Name[sv]=Vte-terminal
+Name[uk]=Термінал Vte
+Name[xh]=Isiphelo se-Vte
+Name[zh_CN]=Vte 终端
+Name[zh_TW]=Vte 終端機
+GenericName=Command Line Terminal
+GenericName[af]=Opdragreëlterminaal
+GenericName[bg]=Терминал с команден ред
+GenericName[cs]=Terminál
+GenericName[da]=Kommandolinje-terminal
+GenericName[de]=Befehlszeilen-Terminal
+GenericName[el]=Τερματικό Γραμμής Εντολών
+GenericName[es]=Terminal de línea de órdenes
+GenericName[et]=Käsurea terminal
+GenericName[fi]=Pääteohjelma
+GenericName[fr]=Terminal de ligne de commande
+GenericName[gl]=Terminal de Liña de Comandos
+GenericName[hu]=Parancssoros terminál
+GenericName[it]=Terminale a riga di comando
+GenericName[ja]=コマンドラインターミナル
+GenericName[km]=ស្ថានីយ​បន្ទាត់​ពាក្យបញ្ជា​
+GenericName[ko]=터미널 명령 라인
+GenericName[lt]=Komandinės eilutės terminalas
+GenericName[mr]=लाईन टर्मिनलचा आदेश
+GenericName[nb]=Vte-terminal
+GenericName[nl]=Commandoregelterminal
+GenericName[pa]=ਕਮਾਂਡ ਲਾਇਨ ਟਰਮੀਨਲ
+GenericName[pl]=Terminal - linia poleceń
+GenericName[pt]=Terminal de Linha de Comando
+GenericName[pt_BR]=Terminal de Linha de Comando
+GenericName[ru]=Терминал командной строки
+GenericName[sv]=Kommandoradsterminal
+GenericName[uk]=Термінал командного рядка
+GenericName[xh]=Isiphelo Somgca Womyalelo
+GenericName[zh_CN]=命令行终端
+GenericName[zh_TW]=指令行終端機
+X-GNOME-Bugzilla-Bugzilla=vte
+X-GNOME-Bugzilla-Product=gnome-terminal
+X-GNOME-Bugzilla-Component=BugBuddyBugs
+X-GNOME-Bugzilla-Version=@VERSION@