aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webkit/webkit-gtk_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/webkit/webkit-gtk_svn.bb')
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index 2e5c0149aa..8473131653 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -1,9 +1,9 @@
DESCRIPTION = "WebKit browser engine, GTK+ edition"
-DEPENDS = "gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
+DEPENDS = "gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
SRCREV_FORMAT = "webcore-rwebkit"
-PV = "1.1.3+svnr${SRCREV}"
+PV = "1.1.4+svnr${SRCREV}"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -31,10 +31,15 @@ EXTRA_OECONF = "\
--enable-debug=no \
--enable-svg \
--enable-icon-database=yes \
- --with-http-backend=soup \
+ --with-http-backend=soup \
"
+
EXTRA_AUTORECONF = " -I autotools "
+do_configure_prepend() {
+ touch gtk-doc.make
+}
+
# Dolt gets used on x86 and ppc and hardcodes 'libtool'
do_configure_append() {
cp ${TARGET_PREFIX}libtool libtool || true