aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wget/wget-1.9.1/m4macros.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wget/wget-1.9.1/m4macros.patch')
-rw-r--r--recipes/wget/wget-1.9.1/m4macros.patch195
1 files changed, 195 insertions, 0 deletions
diff --git a/recipes/wget/wget-1.9.1/m4macros.patch b/recipes/wget/wget-1.9.1/m4macros.patch
new file mode 100644
index 0000000000..eb176750d8
--- /dev/null
+++ b/recipes/wget/wget-1.9.1/m4macros.patch
@@ -0,0 +1,195 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- wget-1.9.1/aclocal.m4~m4macros.patch
++++ wget-1.9.1/aclocal.m4
+@@ -2,6 +2,7 @@
+ dnl Check for `struct utimbuf'.
+ dnl
+
++AH_TEMPLATE([HAVE_STRUCT_UTIMBUF], [Define if we have struct utimbuf])
+ AC_DEFUN([WGET_STRUCT_UTIMBUF],
+ [AC_MSG_CHECKING([for struct utimbuf])
+ if test x"$ac_cv_header_utime_h" = xyes; then
+@@ -21,6 +22,7 @@
+ dnl it. If socklen_t exists, we use it, else if accept() accepts
+ dnl size_t *, we use that, else we use int.
+
++AH_TEMPLATE([socklen_t], [Set to the appropriate type to use for socklen_t])
+ AC_DEFUN([WGET_SOCKLEN_T], [
+ AC_MSG_CHECKING(for socklen_t)
+ AC_TRY_COMPILE([
+@@ -50,6 +52,7 @@
+ dnl even on those because Apache installs its own fnmatch.h to
+ dnl /usr/local/include (!), which GCC uses before /usr/include.
+
++AH_TEMPLATE([HAVE_WORKING_FNMATCH_H], [Define if we have a working fnmatch.h])
+ AC_DEFUN([WGET_FNMATCH], [
+ AC_MSG_CHECKING([for working fnmatch.h])
+ AC_COMPILE_IFELSE([#include <fnmatch.h>
+@@ -61,87 +64,6 @@
+ ])
+ ])
+
+-dnl
+-dnl ansi2knr support: check whether C prototypes are available.
+-dnl
+-
+-AC_DEFUN(AM_C_PROTOTYPES,
+-[AC_REQUIRE([AM_PROG_CC_STDC])
+-AC_BEFORE([$0], [AC_C_INLINE])
+-AC_MSG_CHECKING([for function prototypes])
+-if test "$am_cv_prog_cc_stdc" != no; then
+- AC_MSG_RESULT(yes)
+- AC_DEFINE(PROTOTYPES)
+- U= ANSI2KNR=
+-else
+- AC_MSG_RESULT(no)
+- U=_ ANSI2KNR=./ansi2knr
+- # Ensure some checks needed by ansi2knr itself.
+- AC_HEADER_STDC
+- AC_CHECK_HEADERS(string.h)
+-fi
+-AC_SUBST(U)dnl
+-AC_SUBST(ANSI2KNR)dnl
+-])
+-
+-
+-# serial 1
+-
+-# @defmac AC_PROG_CC_STDC
+-# @maindex PROG_CC_STDC
+-# @ovindex CC
+-# If the C compiler in not in ANSI C mode by default, try to add an option
+-# to output variable @code{CC} to make it so. This macro tries various
+-# options that select ANSI C on some system or another. It considers the
+-# compiler to be in ANSI C mode if it defines @code{__STDC__} to 1 and
+-# handles function prototypes correctly.
+-#
+-# If you use this macro, you should check after calling it whether the C
+-# compiler has been set to accept ANSI C; if not, the shell variable
+-# @code{am_cv_prog_cc_stdc} is set to @samp{no}. If you wrote your source
+-# code in ANSI C, you can make an un-ANSIfied copy of it by using the
+-# program @code{ansi2knr}, which comes with Ghostscript.
+-# @end defmac
+-
+-AC_DEFUN(AM_PROG_CC_STDC,
+-[AC_REQUIRE([AC_PROG_CC])
+-AC_MSG_CHECKING([for ${CC-cc} option to accept ANSI C])
+-AC_CACHE_VAL(am_cv_prog_cc_stdc,
+-[am_cv_prog_cc_stdc=no
+-ac_save_CC="$CC"
+-# Don't try gcc -ansi; that turns off useful extensions and
+-# breaks some systems' header files.
+-# AIX -qlanglvl=ansi
+-# Ultrix and OSF/1 -std1
+-# HP-UX -Aa -D_HPUX_SOURCE
+-for ac_arg in "" -qlanglvl=ansi -std1 "-Aa -D_HPUX_SOURCE"
+-do
+- CC="$ac_save_CC $ac_arg"
+- AC_TRY_COMPILE(
+-[#if !defined(__STDC__)
+-choke me
+-#endif
+-/* DYNIX/ptx V4.1.3 can't compile sys/stat.h with -Xc -D__EXTENSIONS__. */
+-#ifdef _SEQUENT_
+-# include <sys/types.h>
+-# include <sys/stat.h>
+-#endif
+-], [
+-int test (int i, double x);
+-struct s1 {int (*f) (int a);};
+-struct s2 {int (*f) (double a);};],
+-[am_cv_prog_cc_stdc="$ac_arg"; break])
+-done
+-CC="$ac_save_CC"
+-])
+-AC_MSG_RESULT($am_cv_prog_cc_stdc)
+-case "x$am_cv_prog_cc_stdc" in
+- x|xno) ;;
+- *) CC="$CC $am_cv_prog_cc_stdc" ;;
+-esac
+-])
+-
+-
+ dnl ************************************************************
+ dnl START OF IPv6 AUTOCONFIGURATION SUPPORT MACROS
+ dnl ************************************************************
+@@ -294,7 +216,8 @@
+
+ # This code originates from Ulrich Drepper's AM_WITH_NLS.
+
+-AC_DEFUN(WGET_WITH_NLS,
++AH_TEMPLATE([HAVE_NLS], [Define to enable Native Language Support])
++AC_DEFUN([WGET_WITH_NLS],
+ [AC_MSG_CHECKING([whether NLS is requested])
+ dnl Default is enabled NLS
+ AC_ARG_ENABLE(nls,
+@@ -387,7 +310,7 @@
+ dnl This is not strictly an Autoconf macro, because it is run from
+ dnl within `config.status' rather than from within configure. This
+ dnl is why special rules must be applied for it.
+-AC_DEFUN(WGET_PROCESS_PO,
++AC_DEFUN([WGET_PROCESS_PO],
+ [
+ dnl I wonder what the following several lines do...
+ if test "x$srcdir" != "x."; then
+@@ -409,56 +332,3 @@
+ echo "creating po/Makefile"
+ sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in > po/Makefile
+ ])
+-
+-# Search path for a program which passes the given test.
+-# Ulrich Drepper <drepper@cygnus.com>, 1996.
+-#
+-# This file may be copied and used freely without restrictions. It
+-# can be used in projects which are not available under the GNU Public
+-# License but which still want to provide support for the GNU gettext
+-# functionality. Please note that the actual code is *not* freely
+-# available.
+-
+-# serial 1
+-
+-dnl AM_PATH_PROG_WITH_TEST(VARIABLE, PROG-TO-CHECK-FOR,
+-dnl TEST-PERFORMED-ON-FOUND_PROGRAM [, VALUE-IF-NOT-FOUND [, PATH]])
+-AC_DEFUN(AM_PATH_PROG_WITH_TEST,
+-[# Extract the first word of "$2", so it can be a program name with args.
+-set dummy $2; ac_word=[$]2
+-AC_MSG_CHECKING([for $ac_word])
+-AC_CACHE_VAL(ac_cv_path_$1,
+-[case "[$]$1" in
+- /*)
+- ac_cv_path_$1="[$]$1" # Let the user override the test with a path.
+- ;;
+- *)
+- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
+- for ac_dir in ifelse([$5], , $PATH, [$5]); do
+- test -z "$ac_dir" && ac_dir=.
+- if test -f $ac_dir/$ac_word; then
+- if [$3]; then
+- ac_cv_path_$1="$ac_dir/$ac_word"
+- break
+- fi
+- fi
+- done
+- IFS="$ac_save_ifs"
+-dnl If no 4th arg is given, leave the cache variable unset,
+-dnl so AC_PATH_PROGS will keep looking.
+-ifelse([$4], , , [ test -z "[$]ac_cv_path_$1" && ac_cv_path_$1="$4"
+-])dnl
+- ;;
+-esac])dnl
+-$1="$ac_cv_path_$1"
+-if test -n "[$]$1"; then
+- AC_MSG_RESULT([$]$1)
+-else
+- AC_MSG_RESULT(no)
+-fi
+-AC_SUBST($1)dnl
+-])
+-
+-# Include libtool code.
+-
+-builtin(include, libtool.m4)dnl