aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wpa-supplicant/wpa-gui_0.4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wpa-supplicant/wpa-gui_0.4.8.bb')
-rw-r--r--recipes/wpa-supplicant/wpa-gui_0.4.8.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/wpa-supplicant/wpa-gui_0.4.8.bb b/recipes/wpa-supplicant/wpa-gui_0.4.8.bb
new file mode 100644
index 0000000000..4678ba79a2
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-gui_0.4.8.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Qt interface for choosing which configured network to connect \
+to. It also provides a method for browsing 802.11 SSID scan results, an event \
+history log of messages generated by wpa_supplicant, and a method to add or \
+edit wpa_supplicant networks."
+SECTION = "network"
+LICENSE = "GPL BSD"
+HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
+RDEPENDS = "wpa-supplicant"
+PR = "r1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz "
+
+S = "${WORKDIR}/wpa_supplicant-${PV}/wpa_gui/"
+
+inherit qmake qt3x11
+
+EXTRA_QMAKEVARS_POST += "CONFIG+=thread"
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 755 wpa_gui ${D}${sbindir}
+}