aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wrt/loader-0.04/toolchain.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wrt/loader-0.04/toolchain.patch')
-rw-r--r--recipes/wrt/loader-0.04/toolchain.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/wrt/loader-0.04/toolchain.patch b/recipes/wrt/loader-0.04/toolchain.patch
new file mode 100644
index 0000000000..81f92b26e1
--- /dev/null
+++ b/recipes/wrt/loader-0.04/toolchain.patch
@@ -0,0 +1,16 @@
+diff -Nur loader-0.04/Makefile loader-0.04-owrt/Makefile
+--- loader-0.04/Makefile 2005-03-08 11:32:32.000000000 +0100
++++ loader-0.04-owrt/Makefile 2005-04-30 13:44:39.000000000 +0200
+@@ -22,9 +22,10 @@
+
+ OBJCOPY := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+
+-CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
++CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
+ -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
+- -ffunction-sections -pipe -mcpu=r4600 -mips2 -Wa,--trap -m4710a0kern
++ -ffunction-sections -pipe -mlong-calls -fno-common \
++ -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+ CFLAGS += -DLOADADDR=$(TEXT_START) -D_LZMA_IN_CB
+
+ ASFLAGS = $(CFLAGS) -D__ASSEMBLY__ -DBZ_TEXT_START=$(BZ_TEXT_START)