aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wvdial
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wvdial')
-rw-r--r--recipes/wvdial/wvdial-1.56/fixmakefile.patch11
-rw-r--r--recipes/wvdial/wvdial_1.56.bb19
-rw-r--r--recipes/wvdial/wvdial_1.60.bb17
3 files changed, 47 insertions, 0 deletions
diff --git a/recipes/wvdial/wvdial-1.56/fixmakefile.patch b/recipes/wvdial/wvdial-1.56/fixmakefile.patch
new file mode 100644
index 0000000000..38160e61fd
--- /dev/null
+++ b/recipes/wvdial/wvdial-1.56/fixmakefile.patch
@@ -0,0 +1,11 @@
+--- wvdial-1.56/Makefile~ 2009-01-13 21:03:10.000000000 +0100
++++ wvdial-1.56/Makefile 2009-01-13 21:03:10.000000000 +0100
+@@ -38,7 +38,7 @@
+ ifeq ($(WVSTREAMS_LIB),)
+ LIBUNICONF:=-luniconf
+ endif
+-wvdial wvdialconf papchaptest pppmon: wvdial.a $(LIBUNICONF)
++wvdial wvdialconf papchaptest pppmon: wvdial.a
+
+ install-bin: all
+ [ -d ${BINDIR} ] || install -d ${BINDIR}
diff --git a/recipes/wvdial/wvdial_1.56.bb b/recipes/wvdial/wvdial_1.56.bb
new file mode 100644
index 0000000000..878c6b27a1
--- /dev/null
+++ b/recipes/wvdial/wvdial_1.56.bb
@@ -0,0 +1,19 @@
+HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
+DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
+
+PR = "r1"
+
+LICENSE = "LGPL"
+SRC_URI = "http://www.alumnit.ca/download/wvdial-1.56.tar.gz \
+ file://fixmakefile.patch;patch=1"
+
+DEPENDS = "wvstreams"
+RDEPENDS = "ppp"
+
+EXTRA_OEMAKE = ""
+export WVLINK="${LD}"
+LDFLAGS_append = " -luniconf"
+
+do_install() {
+ oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
+}
diff --git a/recipes/wvdial/wvdial_1.60.bb b/recipes/wvdial/wvdial_1.60.bb
new file mode 100644
index 0000000000..29532b241c
--- /dev/null
+++ b/recipes/wvdial/wvdial_1.60.bb
@@ -0,0 +1,17 @@
+HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
+DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
+
+PR = "r1"
+
+LICENSE = "LGPL"
+SRC_URI = "http://www.alumnit.ca/download/wvdial-1.60.tar.gz"
+
+DEPENDS = "wvstreams"
+RDEPENDS = "ppp"
+
+EXTRA_OEMAKE = ""
+export WVLINK="${LD}"
+
+do_install() {
+ oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
+}