aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xkeyboard-config/xkeyboard-config_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xkeyboard-config/xkeyboard-config_1.4.bb')
-rw-r--r--recipes/xkeyboard-config/xkeyboard-config_1.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/xkeyboard-config/xkeyboard-config_1.4.bb b/recipes/xkeyboard-config/xkeyboard-config_1.4.bb
new file mode 100644
index 0000000000..58bb811177
--- /dev/null
+++ b/recipes/xkeyboard-config/xkeyboard-config_1.4.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Common X11 Keyboard layouts"
+LICENSE = "MIT"
+DEPENDS = "intltool xkbcomp-native"
+RDEPENDS = "xkbcomp"
+PR = "r3"
+
+SRC_URI = "http://xlibs.freedesktop.org/xkbdesc/xkeyboard-config-${PV}.tar.bz2 \
+ file://abnt2-fixes.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append () {
+ install -d ${D}/usr/share/X11/xkb/compiled
+ cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
+}
+
+FILES_${PN} += "${datadir}/X11/xkb"