aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib/pixman_0.13.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xorg-lib/pixman_0.13.2.bb')
-rw-r--r--recipes/xorg-lib/pixman_0.13.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/xorg-lib/pixman_0.13.2.bb b/recipes/xorg-lib/pixman_0.13.2.bb
new file mode 100644
index 0000000000..4b489f89a6
--- /dev/null
+++ b/recipes/xorg-lib/pixman_0.13.2.bb
@@ -0,0 +1,23 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DESCRIPTION = "Low-level pixel manipulation library."
+LICENSE = "X11"
+
+PR = "r2"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://cairographics.org/releases/pixman-${PV}.tar.gz \
+ file://pixman-0.13.2-neon1.patch;patch=1 \
+ "
+
+inherit autotools
+
+# We have NEON
+EXTRA_OECONF_append_armv7a = " --disable-arm-simd"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage () {
+ autotools_stage_all
+}
+