aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xserver-kdrive-common/xserver-nodm-init.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xserver-kdrive-common/xserver-nodm-init.bb')
-rw-r--r--recipes/xserver-kdrive-common/xserver-nodm-init.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/xserver-kdrive-common/xserver-nodm-init.bb b/recipes/xserver-kdrive-common/xserver-nodm-init.bb
new file mode 100644
index 0000000000..cba56d55a3
--- /dev/null
+++ b/recipes/xserver-kdrive-common/xserver-nodm-init.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Simple Xserver Init Script (no dm)"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+PR = "r10"
+
+SRC_URI = "file://xserver-nodm"
+S = ${WORKDIR}
+
+PACKAGE_ARCH = "all"
+
+do_install() {
+ install -d ${D}/etc
+ install -d ${D}/etc/init.d
+ install xserver-nodm ${D}/etc/init.d
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "xserver-nodm"
+# start earlier under the assumption that xserver takes seconds to start
+INITSCRIPT_PARAMS = "start 5 5 2 . stop 20 0 1 6 ."
+
+pkg_postinst_${PN} () {
+if test "x$D" = "x"; then
+ for f in `ls /etc/rc?.d/S99${INITSCRIPT_NAME} 2>/dev/null`; do
+ mv $f `dirname $f`/S05${INITSCRIPT_NAME}
+ done
+fi
+}