aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/yum/yum-native_3.2.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/yum/yum-native_3.2.18.bb')
-rw-r--r--recipes/yum/yum-native_3.2.18.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/yum/yum-native_3.2.18.bb b/recipes/yum/yum-native_3.2.18.bb
new file mode 100644
index 0000000000..afe9b02adb
--- /dev/null
+++ b/recipes/yum/yum-native_3.2.18.bb
@@ -0,0 +1,26 @@
+HOMEPAGE = "http://linux.duke.edu/projects/yum/"
+
+SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
+ file://hacks.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://yum-install-recommends.py \
+ file://extract-postinst.awk"
+PR = "r7"
+
+DEPENDS = "rpm-native python-native python-iniparse-native intltool-native \
+ python-urlgrabber-native yum-metadata-parser-native libxml2-native"
+
+S = "${WORKDIR}/yum-${PV}"
+
+inherit autotools native
+
+do_compile_append () {
+ sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum.py
+ sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum-updatesd.py
+}
+
+do_install_append () {
+ install -d ${STAGING_BINDIR}/
+ install ${WORKDIR}/extract-postinst.awk ${STAGING_BINDIR}/
+ install ${WORKDIR}/yum-install-recommends.py ${STAGING_BINDIR}/
+}