aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zaurus-updater/encdec-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zaurus-updater/encdec-updater.bb')
-rw-r--r--recipes/zaurus-updater/encdec-updater.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/zaurus-updater/encdec-updater.bb b/recipes/zaurus-updater/encdec-updater.bb
new file mode 100644
index 0000000000..c03e9b4454
--- /dev/null
+++ b/recipes/zaurus-updater/encdec-updater.bb
@@ -0,0 +1,16 @@
+SECTION = "console/utils"
+LICENSE = "GPL"
+DESCRIPTION = "A tool to encode and decode the Sharp Zaurus updater.sh script"
+
+SRC_URI = "file://encdec-updater.c"
+
+COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
+
+do_compile() {
+ ${CC} -o encdec-updater ${WORKDIR}/encdec-updater.c
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 encdec-updater ${D}${bindir}/
+}