aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zaurus-utils/zaurus-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zaurus-utils/zaurus-updater.bb')
-rw-r--r--recipes/zaurus-utils/zaurus-updater.bb26
1 files changed, 11 insertions, 15 deletions
diff --git a/recipes/zaurus-utils/zaurus-updater.bb b/recipes/zaurus-utils/zaurus-updater.bb
index ee41182cdb..b13e2a36ca 100644
--- a/recipes/zaurus-utils/zaurus-updater.bb
+++ b/recipes/zaurus-utils/zaurus-updater.bb
@@ -1,17 +1,8 @@
DESCRIPTION = "Encrypted shellscript for the Zaurus ROM update"
-DEPENDS = "encdec-updater-native"
LICENSE = "zaurus-updater"
+DEPENDS = "encdec-updater-native"
PR = "r25"
-# even though the package is not machine-specific
-# we have to force it there to allow multimachine builds
-# because DEPLOY_DIR_IMAGE = "${DEPLOY_DIR}/images/${MACHINE}"
-# and without this only the first machine built get the right staging ipk
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-PACKAGES = ""
-COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
-
SRC_URI = "file://updater.sh"
S = "${WORKDIR}"
@@ -19,17 +10,22 @@ S = "${WORKDIR}"
do_configure() {
sed -i "s/ZAURUS_UPDATER_VERSION/${PR}/" "${S}/updater.sh"
}
-
do_compile() {
encdec-updater -e updater.sh
}
+# even though the package is not machine-specific
+# we have to force it there to allow multimachine builds
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = ""
+
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile
+
+COMPATIBLE_MACHINE = "(poodle|c7x0|spitz|akita|tosa)"
+
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
install -m 0755 updater.sh ${DEPLOY_DIR_IMAGE}/updater.sh
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/updater.sh
}
-
-# package_stagefile_shell need to run before populate_sysroot for packaged-staging
-addtask deploy before do_populate_sysroot after do_compile
-