aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zddice/zddice_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zddice/zddice_1.0.0.bb')
-rw-r--r--recipes/zddice/zddice_1.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/zddice/zddice_1.0.0.bb b/recipes/zddice/zddice_1.0.0.bb
new file mode 100644
index 0000000000..068c39c3a9
--- /dev/null
+++ b/recipes/zddice/zddice_1.0.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Zaurus D20 Gaming Dice for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zddice/zddice_${PV}_arm.src.tar.gz \
+ file://qtopia17.patch;patch=1"
+S = "${WORKDIR}/zddice-src"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
+
+do_install() {
+ install -d ${D}${palmtopdir}/{bin,pics,apps/Games}
+ install -m 0755 zddice ${D}${palmtopdir}/bin/
+ install -m 0644 images/zddice.png ${D}${palmtopdir}/pics/
+ install -m 0644 zddice.desktop ${D}${palmtopdir}/apps/Games/
+}