aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zip/zip.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zip/zip.inc')
-rw-r--r--recipes/zip/zip.inc19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/zip/zip.inc b/recipes/zip/zip.inc
new file mode 100644
index 0000000000..8d04bd5f61
--- /dev/null
+++ b/recipes/zip/zip.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Archiver for .zip files"
+SECTION = "console/utils"
+LICENSE = "Info-ZIP"
+
+SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip${@bb.data.getVar('PV',d,1).replace('.', '')}.tar.gz"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
+ 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
+ 'BINFLAGS=0755' 'INSTALL_D=install -d'"
+
+do_compile() {
+ oe_runmake -f unix/Makefile generic
+}
+
+do_install() {
+ oe_runmake -f unix/Makefile prefix=${D}${prefix} \
+ BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
+ install
+}