aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zsh/zsh_4.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zsh/zsh_4.1.1.bb')
-rw-r--r--recipes/zsh/zsh_4.1.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/zsh/zsh_4.1.1.bb b/recipes/zsh/zsh_4.1.1.bb
new file mode 100644
index 0000000000..3c5cc85b83
--- /dev/null
+++ b/recipes/zsh/zsh_4.1.1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "The Zsh shell"
+SECTION = "base/shell"
+PRIORITY = "optional"
+DEPENDS = "ncurses libpcre"
+PR = "r2"
+LICENSE = "zsh"
+
+SRC_URI = "http://www.zsh.org/pub/old/zsh-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-curses-terminfo"
+PARALLEL_MAKE = ""
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cat aczsh.m4 > acinclude.m4
+ fi
+}
+
+#kill symlink
+do_install_append () {
+ mv ${D}${bindir}/zsh-${PV} ${D}${bindir}/zsh
+}