aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/iperf/iperf.inc25
-rw-r--r--recipes/iperf/iperf_2.0.2.bb26
2 files changed, 26 insertions, 25 deletions
diff --git a/recipes/iperf/iperf.inc b/recipes/iperf/iperf.inc
new file mode 100644
index 0000000000..07a8064744
--- /dev/null
+++ b/recipes/iperf/iperf.inc
@@ -0,0 +1,25 @@
+SECTION = "console/network"
+DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
+HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
+LICENSE = "BSD"
+PR = "r0"
+
+inherit autotools
+
+S="${WORKDIR}/iperf-${PV}"
+
+# --disable-threads is needed on epia/x86 with uclibc
+do_configure() {
+ gnu-configize
+ oe_runconf --exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix} --disable-threads
+}
+
+do_compile() {
+ cd ${WORKDIR}/iperf-${PV}
+ oe_runmake
+}
+
+do_install() {
+ cd ${WORKDIR}/iperf-${PV}/src
+ oe_runmake DESTDIR=${D} install
+}
diff --git a/recipes/iperf/iperf_2.0.2.bb b/recipes/iperf/iperf_2.0.2.bb
index 28d009ad58..7235a89695 100644
--- a/recipes/iperf/iperf_2.0.2.bb
+++ b/recipes/iperf/iperf_2.0.2.bb
@@ -1,28 +1,4 @@
-SECTION = "console/network"
-DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
-HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
-LICENSE = "BSD"
-PR = "r0"
+require iperf.inc
SRC_URI = "http://dast.nlanr.net/Projects/Iperf2.0/iperf-${PV}.tar.gz"
-# file://socketaddr-h-errno.diff;patch=1"
-inherit autotools
-
-S="${WORKDIR}/iperf-${PV}"
-
-# --disable-threads is needed on epia/x86 with uclibc
-do_configure() {
- gnu-configize
- oe_runconf --exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix} --disable-threads
-}
-
-do_compile() {
- cd ${WORKDIR}/iperf-${PV}
- oe_runmake
-}
-
-do_install() {
- cd ${WORKDIR}/iperf-${PV}/src
- oe_runmake DESTDIR=${D} install
-}