summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/apr/apr-1.3.5/cleanup.patch42
-rw-r--r--recipes/apr/apr_1.3.5.bb4
2 files changed, 44 insertions, 2 deletions
diff --git a/recipes/apr/apr-1.3.5/cleanup.patch b/recipes/apr/apr-1.3.5/cleanup.patch
new file mode 100644
index 0000000000..53623a2666
--- /dev/null
+++ b/recipes/apr/apr-1.3.5/cleanup.patch
@@ -0,0 +1,42 @@
+Index: apr-1.3.5/build/buildcheck.sh
+===================================================================
+--- apr-1.3.5.orig/build/buildcheck.sh 2009-02-23 20:37:18.000000000 -0700
++++ apr-1.3.5/build/buildcheck.sh 2010-09-09 11:09:08.000000000 -0700
+@@ -31,36 +31,4 @@
+ else
+ echo "buildconf: autoconf version $ac_version (ok)"
+ fi
+-
+-# Sample libtool --version outputs:
+-# ltmain.sh (GNU libtool) 1.3.3 (1.385.2.181 1999/07/02 15:49:11)
+-# ltmain.sh (GNU libtool 1.1361 2004/01/02 23:10:52) 1.5a
+-# output is multiline from 1.5 onwards
+-
+-# Require libtool 1.4 or newer
+-libtool=`build/PrintPath glibtool1 glibtool libtool libtool15 libtool14`
+-lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
+-if test -z "$lt_pversion"; then
+-echo "buildconf: libtool not found."
+-echo " You need libtool version 1.4 or newer installed"
+-echo " to build APR from SVN."
+-exit 1
+-fi
+-lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
+-IFS=.; set $lt_version; IFS=' '
+-lt_status="good"
+-if test "$1" = "1"; then
+- if test "$2" -lt "4"; then
+- lt_status="bad"
+- fi
+-fi
+-if test $lt_status = "good"; then
+- echo "buildconf: libtool version $lt_pversion (ok)"
+- exit 0
+-fi
+-
+-echo "buildconf: libtool version $lt_pversion found."
+-echo " You need libtool version 1.4 or newer installed"
+-echo " to build APR from SVN."
+-
+-exit 1
++exit 0
diff --git a/recipes/apr/apr_1.3.5.bb b/recipes/apr/apr_1.3.5.bb
index a8362e4165..955334f279 100644
--- a/recipes/apr/apr_1.3.5.bb
+++ b/recipes/apr/apr_1.3.5.bb
@@ -2,11 +2,11 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
SECTION = "libs"
LICENSE = "Apache License, Version 2.0"
-PR = "r4"
+PR = "r5"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2;name=apr135tarbz2 \
file://configure_fixes.patch \
-# file://cleanup.patch \
+ file://cleanup.patch \
file://configfix.patch"
inherit autotools lib_package binconfig