summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gcc/files/gcc-posix-open-fix.patch (renamed from recipes/gcc/gcc-3.4.4/gcc-posix.patch)0
-rw-r--r--recipes/gcc/gcc-3.4.4.inc2
-rw-r--r--recipes/gcc/gcc-3.4.6.inc2
-rw-r--r--recipes/gcc/gcc-3.4.6/gcc-posix.patch11
4 files changed, 2 insertions, 13 deletions
diff --git a/recipes/gcc/gcc-3.4.4/gcc-posix.patch b/recipes/gcc/files/gcc-posix-open-fix.patch
index 99f813e866..99f813e866 100644
--- a/recipes/gcc/gcc-3.4.4/gcc-posix.patch
+++ b/recipes/gcc/files/gcc-posix-open-fix.patch
diff --git a/recipes/gcc/gcc-3.4.4.inc b/recipes/gcc/gcc-3.4.4.inc
index 0b5b714e09..2bed5f8959 100644
--- a/recipes/gcc/gcc-3.4.4.inc
+++ b/recipes/gcc/gcc-3.4.4.inc
@@ -22,6 +22,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://gcc34-configure.in.patch;patch=1 \
file://gcc34-thumb-support.patch;patch=1 \
file://gcc-cross-fixincl.patch;patch=1 \
- file://gcc-posix.patch;patch=1 \
+ file://gcc-posix-open-fix.patch;patch=1 \
"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/recipes/gcc/gcc-3.4.6.inc b/recipes/gcc/gcc-3.4.6.inc
index b1f686b365..faab40623e 100644
--- a/recipes/gcc/gcc-3.4.6.inc
+++ b/recipes/gcc/gcc-3.4.6.inc
@@ -16,7 +16,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://always-fixincperm.patch;patch=1 \
file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \
file://zecke-xgcc-cpp.patch;patch=1 \
- file://gcc-posix.patch;patch=1 \
+ file://gcc-posix-open-fix.patch;patch=1 \
file://gcc4-mtune-compat.patch;patch=1"
SRC_URI += "file://gcc34-configure.in.patch;patch=1"
diff --git a/recipes/gcc/gcc-3.4.6/gcc-posix.patch b/recipes/gcc/gcc-3.4.6/gcc-posix.patch
deleted file mode 100644
index 99f813e866..0000000000
--- a/recipes/gcc/gcc-3.4.6/gcc-posix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc-3.4.6/gcc/collect2.c 2008-10-04 18:17:17.796750393 +0400
-+++ gcc-3.4.6/gcc/collect2.new 2008-10-04 18:24:10.120748711 +0400
-@@ -1534,7 +1534,7 @@ collect_execute (const char *prog, char
- if (redir)
- {
- /* Open response file. */
-- redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT);
-+ redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT, S_IWUSR);
-
- /* Duplicate the stdout and stderr file handles
- so they can be restored later. */