aboutsummaryrefslogtreecommitdiffstats
path: root/rp-pppoe/rp-pppoe-3.5
diff options
context:
space:
mode:
Diffstat (limited to 'rp-pppoe/rp-pppoe-3.5')
-rw-r--r--rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_configure_in_cross.diff56
-rw-r--r--rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_libevent_makefile_cross.diff34
-rw-r--r--rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_no_strip.diff19
3 files changed, 109 insertions, 0 deletions
diff --git a/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_configure_in_cross.diff b/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_configure_in_cross.diff
index e69de29bb2..a382f06fff 100644
--- a/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_configure_in_cross.diff
+++ b/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_configure_in_cross.diff
@@ -0,0 +1,56 @@
+--- rp-pppoe-3.5.clean/src/configure.in 2002-07-08 16:38:24.000000000 +0200
++++ rp-pppoe-3.5/src/configure.in 2004-08-06 19:24:56.593931152 +0200
+@@ -131,13 +131,16 @@
+
+ dnl Check for Linux-specific kernel support for PPPoE
+ AC_MSG_CHECKING(for Linux 2.4.X kernel-mode PPPoE support)
+-if test "`uname -s`" = "Linux" ; then
++AC_CACHE_VAL(ac_cv_linux_kernel_pppoe,[
++if test "`uname -s`" = "Linux"; then
++if test $cross_compiling = "no"; then
+ dnl Do a bunch of modprobes. Can't hurt; might help.
+ modprobe ppp_generic > /dev/null 2>&1
+ modprobe ppp_async > /dev/null 2>&1
+ modprobe n_hdlc > /dev/null 2>&1
+ modprobe ppp_synctty > /dev/null 2>&1
+ modprobe pppoe > /dev/null 2>&1
++fi
+ AC_TRY_RUN([#include <sys/socket.h>
+ #include <net/ethernet.h>
+ #include <linux/if.h>
+@@ -146,10 +149,11 @@
+ {
+ if (socket(AF_PPPOX, SOCK_DGRAM, PX_PROTO_OE) >= 0) return 0; else return 1;
+ }
+-], ac_cv_linux_kernel_pppoe=yes, ac_cv_linux_kernel_pppoe=no)
++], ac_cv_linux_kernel_pppoe=yes, ac_cv_linux_kernel_pppoe=no, [ac_cv_linux_kernel_pppoe=no; $ECHO "cross-compiling, default: "] )
+ else
+ ac_cv_linux_kernel_pppoe=no
+ fi
++])
+
+ $ECHO $ac_cv_linux_kernel_pppoe
+ if test "$ac_cv_linux_kernel_pppoe" != yes ; then
+@@ -208,7 +212,7 @@
+ esac
+
+ dnl Figure out packing order of structures
+-AC_MSG_CHECKING(packing order of bit fields)
++AC_CACHE_CHECK([packing order of bit fields],rpppoe_cv_pack_bitfields,[
+ AC_TRY_RUN([
+ union foo {
+ struct bar {
+@@ -231,9 +235,11 @@
+ } else {
+ return 2;
+ }
+-}], PACK=normal, PACK=rev)
++}], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev,
++$ECHO "no defaults for cross-compiling"; exit 0)
++])
+
+-if test "$PACK" = "rev" ; then
++if test "$rpppoe_cv_pack_bitfields" = "rev" ; then
+ $ECHO "reversed"
+ AC_DEFINE(PACK_BITFIELDS_REVERSED)
+ else
diff --git a/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_libevent_makefile_cross.diff b/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_libevent_makefile_cross.diff
index e69de29bb2..70b26e9ef8 100644
--- a/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_libevent_makefile_cross.diff
+++ b/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_libevent_makefile_cross.diff
@@ -0,0 +1,34 @@
+--- rp-pppoe-3.5.clean/src/libevent/Makefile.in 2002-07-08 16:38:24.000000000 +0200
++++ rp-pppoe-3.5/src/libevent/Makefile.in 2004-08-06 19:38:02.614437872 +0200
+@@ -13,25 +13,26 @@
+ SRCS=$(OBJS:.o=.c)
+ HDRS=event.h event_tcp.h eventpriv.h hash.h
+ CFLAGS=@CFLAGS@ -I..
++AR=ar
+
+ all: libevent.a
+
+ libevent.a: $(OBJS)
+ rm -f libevent.a
+- ar -cq libevent.a $(OBJS)
++ $(AR) -cq libevent.a $(OBJS)
+ @RANLIB@ libevent.a
+
+ event.o: event.c $(HDRS)
+- gcc $(CFLAGS) -c -o event.o event.c
++ @CC@ $(CFLAGS) -c -o event.o event.c
+
+ hash.o: hash.c $(HDRS)
+- gcc $(CFLAGS) -c -o hash.o hash.c
++ @CC@ $(CFLAGS) -c -o hash.o hash.c
+
+ event_sig.o: event_sig.c $(HDRS)
+- gcc $(CFLAGS) -c -o event_sig.o event_sig.c
++ @CC@ $(CFLAGS) -c -o event_sig.o event_sig.c
+
+ event_tcp.o: event_tcp.c $(HDRS)
+- gcc $(CFLAGS) -c -o event_tcp.o event_tcp.c
++ @CC@ $(CFLAGS) -c -o event_tcp.o event_tcp.c
+
+ clean: FORCE
+ rm -f *.a *.o *~
diff --git a/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_no_strip.diff b/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_no_strip.diff
index e69de29bb2..55bb395e96 100644
--- a/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_no_strip.diff
+++ b/rp-pppoe/rp-pppoe-3.5/rp-pppoe-3.5_no_strip.diff
@@ -0,0 +1,19 @@
+--- rp-pppoe-3.5.clean/src/Makefile.in 2002-07-08 16:38:24.000000000 +0200
++++ rp-pppoe-3.5/src/Makefile.in 2004-08-06 19:49:46.720397496 +0200
+@@ -135,11 +135,11 @@
+
+ install: all
+ -mkdir -p $(RPM_INSTALL_ROOT)$(sbindir)
+- $(install) -m 755 -s pppoe $(RPM_INSTALL_ROOT)$(sbindir)
+- $(install) -m 755 -s pppoe-server $(RPM_INSTALL_ROOT)$(sbindir)
+- if test -x licensed-only/pppoe-server-control ; then $(install) -m 755 -s licensed-only/pppoe-server-control $(RPM_INSTALL_ROOT)$(sbindir); fi
+- if test -x pppoe-relay ; then $(install) -m 755 -s pppoe-relay $(RPM_INSTALL_ROOT)$(sbindir); fi
+- if test -x pppoe-sniff; then $(install) -m 755 -s pppoe-sniff $(RPM_INSTALL_ROOT)$(sbindir); fi
++ $(install) -m 755 pppoe $(RPM_INSTALL_ROOT)$(sbindir)
++ $(install) -m 755 pppoe-server $(RPM_INSTALL_ROOT)$(sbindir)
++ if test -x licensed-only/pppoe-server-control ; then $(install) -m 755 licensed-only/pppoe-server-control $(RPM_INSTALL_ROOT)$(sbindir); fi
++ if test -x pppoe-relay ; then $(install) -m 755 pppoe-relay $(RPM_INSTALL_ROOT)$(sbindir); fi
++ if test -x pppoe-sniff; then $(install) -m 755 pppoe-sniff $(RPM_INSTALL_ROOT)$(sbindir); fi
+ $(install) -m 755 ../scripts/adsl-connect $(RPM_INSTALL_ROOT)$(sbindir)
+ $(install) -m 755 ../scripts/adsl-start $(RPM_INSTALL_ROOT)$(sbindir)
+ $(install) -m 755 ../scripts/adsl-status $(RPM_INSTALL_ROOT)$(sbindir)