aboutsummaryrefslogtreecommitdiffstats
path: root/sdlperl/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sdlperl/Makefile.patch')
-rw-r--r--sdlperl/Makefile.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/sdlperl/Makefile.patch b/sdlperl/Makefile.patch
index e69de29bb2..ae20c08c77 100644
--- a/sdlperl/Makefile.patch
+++ b/sdlperl/Makefile.patch
@@ -0,0 +1,17 @@
+--- Makefile.linux.orig 2004-06-25 12:44:53.000000000 +0100
++++ Makefile.linux 2004-06-25 12:45:37.000000000 +0100
+@@ -119,12 +119,12 @@
+ my %options = (
+ 'NAME' => 'SDL_perl',
+ 'VERSION_FROM' => 'lib/SDL.pm',
+- 'LIBS' => [ join( " ", "$sdl_libs",
++ 'LIBS' => [ join( " ", $ENV{"LDFLAGS"}, "$sdl_libs",
+ map { $ext{$_}{exists} ? "-l$_" : '' } (sort keys %ext),
+ )
+ ],
+ 'DEFINE' => join ( " ", @defs, map { $ext{$_}{exists} ? "-D$ext{$_}{inc}" : '' } sort keys %ext),
+- 'INC' => "$inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
++ 'INC' => $ENV{"CFLAGS"} . " $inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
+ 'OBJECT' => (
+ ($ext{SDL_image}{exists} ? 'SFont.o ' : "") .
+ 'SDL_perl.o ' .