aboutsummaryrefslogtreecommitdiffstats
path: root/sparse/files/vars.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sparse/files/vars.patch')
-rw-r--r--sparse/files/vars.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sparse/files/vars.patch b/sparse/files/vars.patch
index e69de29bb2..353df2ad0b 100644
--- a/sparse/files/vars.patch
+++ b/sparse/files/vars.patch
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sparse-bk/Makefile~vars 2004-09-13 17:45:43.304134000 -0400
++++ sparse-bk/Makefile 2004-09-13 17:46:04.980839384 -0400
+@@ -1,4 +1,5 @@
+ CC=gcc
++CCLD=gcc
+ CFLAGS=-O -g -Wall
+ LDFLAGS=-g
+ AR=ar
+@@ -26,22 +27,22 @@
+ if test $< -nt $(PREFIX)/bin/sparse ; then install -v $< $(PREFIX)/bin/sparse ; fi
+
+ test-lexing: test-lexing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-parsing: test-parsing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-linearize: test-linearize.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ compile: compile.o compile-i386.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
+
+ obfuscate: obfuscate.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ check: check.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ $(LIB_FILE): $(LIB_OBJS)
+ $(AR) rcs $(LIB_FILE) $(LIB_OBJS)