aboutsummaryrefslogtreecommitdiffstats
path: root/udev/udev-042/flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'udev/udev-042/flags.patch')
-rw-r--r--udev/udev-042/flags.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/udev/udev-042/flags.patch b/udev/udev-042/flags.patch
index e69de29bb2..a5a791df33 100644
--- a/udev/udev-042/flags.patch
+++ b/udev/udev-042/flags.patch
@@ -0,0 +1,67 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udev-042/Makefile~flags
++++ udev-042/Makefile
+@@ -119,16 +119,18 @@
+ endif
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DLOG
++ override CFLAGS += -DLOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip or optimize
++override CFLAGS += -D_GNU_SOURCE
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -O1 -g -DDEBUG -D_GNU_SOURCE
++ CFLAGS += -O1 -g
++ override CFLAGS += -DDEBUG
+ LDFLAGS += -Wl,-warn-common
+ STRIPCMD = /bin/true -Since_we_are_debugging
+ else
+- CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer -D_GNU_SOURCE
++ CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer
+ LDFLAGS += -s -Wl,-warn-common
+ STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
+ endif
+@@ -150,8 +152,8 @@
+
+ CRT0 = $(KLIBC_DIR)/crt0.o
+ LIBC = $(ARCH_LIB_OBJS) $(LIB_OBJS) $(CRT0)
+- CFLAGS += $(WARNINGS) -nostdinc \
+- $(OPTFLAGS) \
++ CFLAGS += $(WARNINGS) $(OPTFLAGS)
++ override CFLAGS += -nostdinc \
+ -D__KLIBC__ -fno-builtin-printf \
+ -I$(KLIBC_FIXUPS_DIR) \
+ -include $(KLIBC_FIXUPS_DIR)/klibc_fixups.h \
+@@ -161,12 +163,13 @@
+ -I$(GCCINCDIR) \
+ -I$(LINUX_INCLUDE_DIR)
+ LIB_OBJS =
+- LDFLAGS = --static --nostdlib -nostartfiles -nodefaultlibs
++ override LDFLAGS += --static --nostdlib -nostartfiles -nodefaultlibs
+ else
+ WARNINGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+ CRT0 =
+ LIBC =
+- CFLAGS += $(WARNINGS) -I$(GCCINCDIR)
++ CFLAGS += $(WARNINGS)
++ override CFLAGS += -I$(GCCINCDIR)
+ LIB_OBJS = -lc
+ LDFLAGS =
+ endif
+@@ -176,8 +179,8 @@
+ LIB_OBJS += -lselinux
+ endif
+
+-CFLAGS += -I$(PWD)/libsysfs/sysfs \
+- -I$(PWD)/libsysfs
++override CFLAGS += -I$(PWD)/libsysfs/sysfs \
++ -I$(PWD)/libsysfs
+
+ # config files automatically generated
+ GEN_CONFIGS = $(LOCAL_CFG_DIR)/udev.conf