aboutsummaryrefslogtreecommitdiffstats
path: root/xprop/xprop/autofoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'xprop/xprop/autofoo.patch')
-rw-r--r--xprop/xprop/autofoo.patch271
1 files changed, 271 insertions, 0 deletions
diff --git a/xprop/xprop/autofoo.patch b/xprop/xprop/autofoo.patch
index e69de29bb2..b09ba94c9a 100644
--- a/xprop/xprop/autofoo.patch
+++ b/xprop/xprop/autofoo.patch
@@ -0,0 +1,271 @@
+diff -urN xprop.orig/Imakefile xprop/Imakefile
+--- xprop.orig/Imakefile 2004-04-23 21:55:03.000000000 +0200
++++ xprop/Imakefile 1970-01-01 01:00:00.000000000 +0100
+@@ -1,18 +0,0 @@
+-XCOMM $Xorg: Imakefile,v 1.3 2000/08/17 19:54:55 cpqbld Exp $
+-
+-
+-
+-
+-XCOMM $XFree86: xc/programs/xprop/Imakefile,v 1.5tsi Exp $
+-
+- DEPLIBS = $(DEPXMUULIB) $(DEPXONLYLIB)
+-LOCAL_LIBRARIES = $(XMUULIB) $(XONLYLIB)
+- SRCS = xprop.c dsimple.c
+- OBJS = xprop.o dsimple.o
+-
+- DEFINES = XawI18nDefines
+-
+-LinkSourceFile(dsimple.c,../xlsfonts)
+-LinkSourceFile(dsimple.h,../xlsfonts)
+-
+-ComplexProgramTarget(xprop)
+diff -urN xprop.orig/Makefile.am xprop/Makefile.am
+--- xprop.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ xprop/Makefile.am 2004-08-15 18:49:43.000000000 +0200
+@@ -0,0 +1,53 @@
++#
++# $Id$
++#
++# Copyright © 2003 Keith Packard
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of Keith Packard not be used in
++# advertising or publicity pertaining to distribution of the software without
++# specific, written prior permission. Keith Packard makes no
++# representations about the suitability of this software for any purpose. It
++# is provided "as is" without express or implied warranty.
++#
++# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++# PERFORMANCE OF THIS SOFTWARE.
++#
++
++AUTOMAKE_OPTIONS = 1.7 foreign
++
++AM_CFLAGS = @XPROP_CFLAGS@
++
++bin_PROGRAMS = xprop
++
++xprop_SOURCES = dsimple.c dsimple.h xprop.c
++
++xprop_LDADD = @XPROP_LIBS@
++
++man5_MANS=xprop.man
++
++EXTRA_DIST= $(man5_MANS)
++
++MAINTAINERCLEANFILES = configure \
++config.guess \
++config.sub \
++install-sh \
++ltmain.sh \
++missing \
++mkinstalldirs \
++aclocal.m4 \
++Makefile.in \
++depcomp \
++autoscan.log \
++configure.scan \
++config.h \
++config.h.in \
++$(man5_MANS)
+diff -urN xprop.orig/configure.ac xprop/configure.ac
+--- xprop.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ xprop/configure.ac 2004-08-15 19:00:43.000000000 +0200
+@@ -0,0 +1,44 @@
++dnl
++dnl $Id$
++dnl
++dnl Copyright © 2003 Keith Packard
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this software and its
++dnl documentation for any purpose is hereby granted without fee, provided that
++dnl the above copyright notice appear in all copies and that both that
++dnl copyright notice and this permission notice appear in supporting
++dnl documentation, and that the name of Keith Packard not be used in
++dnl advertising or publicity pertaining to distribution of the software without
++dnl specific, written prior permission. Keith Packard makes no
++dnl representations about the suitability of this software for any purpose. It
++dnl is provided "as is" without express or implied warranty.
++dnl
++dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++dnl PERFORMANCE OF THIS SOFTWARE.
++dnl
++
++AC_PREREQ(2.57)
++AC_INIT([xprop],4.4.0,[],xprop)
++AC_CONFIG_SRCDIR([Makefile.am])
++AM_INIT_AUTOMAKE([dist-bzip2])
++AM_MAINTAINER_MODE
++AM_CONFIG_HEADER(config.h)
++
++AC_PROG_CC
++AC_PROG_INSTALL
++AC_PROG_LN_S
++AC_LIBTOOL_WIN32_DLL
++AM_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++PKG_CHECK_MODULES(XPROP, xext xmu x11)
++
++AC_CHECK_HEADERS([wchar.h])
++AC_CHECK_HEADERS([wctype.h])
++
++AC_OUTPUT([Makefile])
+diff -urN xprop.orig/dsimple.c xprop/dsimple.c
+--- xprop.orig/dsimple.c 2003-11-14 16:54:54.000000000 +0100
++++ xprop/dsimple.c 2004-08-15 19:19:32.000000000 +0200
+@@ -27,11 +27,16 @@
+
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ /*
+ * Other_stuff.h: Definitions of routines in other_stuff.
+ *
+@@ -69,7 +74,7 @@
+ char *Malloc(size)
+ unsigned size;
+ {
+- char *data, *malloc();
++ char *data;
+
+ if (!(data = malloc(size)))
+ Fatal_Error("Out of memory!");
+@@ -85,7 +90,7 @@
+ char *ptr;
+ int size;
+ {
+- char *new_ptr, *realloc();
++ char *new_ptr;
+
+ if (!ptr)
+ return(Malloc(size));
+diff -urN xprop.orig/xprop.c xprop/xprop.c
+--- xprop.orig/xprop.c 2004-04-23 21:55:03.000000000 +0200
++++ xprop/xprop.c 2004-08-15 19:23:13.000000000 +0200
+@@ -30,6 +30,10 @@
+ /* $XFree86: xc/programs/xprop/xprop.c,v 1.15 2003/09/24 02:43:38 dawes Exp $ */
+
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include <X11/Xlib.h>
+ #include <X11/Xos.h>
+ #include <X11/Xfuncs.h>
+@@ -1279,6 +1283,45 @@
+ }
+ }
+
++/*
++ *
++ * Routines for parsing command line:
++ *
++ */
++
++void
++usage (void)
++{
++ char **cpp;
++ static char *help_message[] = {
++"where options include:",
++" -grammar print out full grammar for command line",
++" -display host:dpy the X server to contact",
++" -id id resource id of window to examine",
++" -name name name of window to examine",
++" -font name name of font to examine",
++" -remove propname remove a property",
++" -set propname value set a property to a given value",
++" -root examine the root window",
++" -len n display at most n bytes of any property",
++" -notype do not display the type field",
++" -fs filename where to look for formats for properties",
++" -frame don't ignore window manager frames",
++" -f propname format [dformat] formats to use for property of given name",
++" -spy examine window properties forever",
++NULL};
++
++ fflush (stdout);
++ fprintf (stderr,
++ "usage: %s [-options ...] [[format [dformat]] atom] ...\n\n",
++ program_name);
++ for (cpp = help_message; *cpp; cpp++) {
++ fprintf (stderr, "%s\n", *cpp);
++ }
++ fprintf (stderr, "\n");
++ exit (1);
++}
++
+ static thunk *
+ Handle_Prop_Requests (int argc, char **argv)
+ {
+@@ -1502,45 +1545,6 @@
+ data, nelements);
+ }
+
+-/*
+- *
+- * Routines for parsing command line:
+- *
+- */
+-
+-void
+-usage (void)
+-{
+- char **cpp;
+- static char *help_message[] = {
+-"where options include:",
+-" -grammar print out full grammar for command line",
+-" -display host:dpy the X server to contact",
+-" -id id resource id of window to examine",
+-" -name name name of window to examine",
+-" -font name name of font to examine",
+-" -remove propname remove a property",
+-" -set propname value set a property to a given value",
+-" -root examine the root window",
+-" -len n display at most n bytes of any property",
+-" -notype do not display the type field",
+-" -fs filename where to look for formats for properties",
+-" -frame don't ignore window manager frames",
+-" -f propname format [dformat] formats to use for property of given name",
+-" -spy examine window properties forever",
+-NULL};
+-
+- fflush (stdout);
+- fprintf (stderr,
+- "usage: %s [-options ...] [[format [dformat]] atom] ...\n\n",
+- program_name);
+- for (cpp = help_message; *cpp; cpp++) {
+- fprintf (stderr, "%s\n", *cpp);
+- }
+- fprintf (stderr, "\n");
+- exit (1);
+-}
+-
+ static void
+ grammar (void)
+ {