aboutsummaryrefslogtreecommitdiffstats
path: root/xrdb/xrdb/autofoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'xrdb/xrdb/autofoo.patch')
-rw-r--r--xrdb/xrdb/autofoo.patch132
1 files changed, 132 insertions, 0 deletions
diff --git a/xrdb/xrdb/autofoo.patch b/xrdb/xrdb/autofoo.patch
index e69de29bb2..9c00673afb 100644
--- a/xrdb/xrdb/autofoo.patch
+++ b/xrdb/xrdb/autofoo.patch
@@ -0,0 +1,132 @@
+diff -urN xrdb.orig/Imakefile xrdb/Imakefile
+--- xrdb.orig/Imakefile 2004-04-23 21:55:03.000000000 +0200
++++ xrdb/Imakefile 1970-01-01 01:00:00.000000000 +0100
+@@ -1,19 +0,0 @@
+-XCOMM $Xorg: Imakefile,v 1.3 2000/08/17 19:54:56 cpqbld Exp $
+-
+-
+-
+-
+-XCOMM $XFree86: xc/programs/xrdb/Imakefile,v 3.6tsi Exp $
+-
+-#ifdef PatheticCpp
+- CPPDEFS = -DPATHETICCPP
+-#endif
+-#if HasMkstemp
+- CPPDEFS = -DHAS_MKSTEMP
+-#endif
+-XCOMM Due to ill make parsing the cpp is passed directly in source file
+- DEFINES = -DCPP="\"$(CPP)\"" $(CPPDEFS)
+- DEPLIBS = $(DEPXMUULIB) $(DEPXONLYLIB)
+-LOCAL_LIBRARIES = $(XMUULIB) $(XONLYLIB)
+-
+-SimpleProgramTarget(xrdb)
+diff -urN xrdb.orig/Makefile.am xrdb/Makefile.am
+--- xrdb.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ xrdb/Makefile.am 2004-08-14 16:05:01.000000000 +0200
+@@ -0,0 +1,53 @@
++#
++# $Id$
++#
++# Copyright © 2003 Keith Packard
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of Keith Packard not be used in
++# advertising or publicity pertaining to distribution of the software without
++# specific, written prior permission. Keith Packard makes no
++# representations about the suitability of this software for any purpose. It
++# is provided "as is" without express or implied warranty.
++#
++# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++# PERFORMANCE OF THIS SOFTWARE.
++#
++
++AUTOMAKE_OPTIONS = 1.7 foreign
++
++AM_CFLAGS = @XRDB_CFLAGS@
++
++bin_PROGRAMS = xrdb
++
++xrdb_SOURCES = xrdb.c
++
++xrdb_LDADD = @XRDB_LIBS@
++
++man5_MANS=xrdb.man
++
++EXTRA_DIST= $(man5_MANS)
++
++MAINTAINERCLEANFILES = configure \
++config.guess \
++config.sub \
++install-sh \
++ltmain.sh \
++missing \
++mkinstalldirs \
++aclocal.m4 \
++Makefile.in \
++depcomp \
++autoscan.log \
++configure.scan \
++config.h \
++config.h.in \
++$(man5_MANS)
+diff -urN xrdb.orig/autogen.sh xrdb/autogen.sh
+--- xrdb.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
++++ xrdb/autogen.sh 2004-08-14 15:57:35.000000000 +0200
+@@ -0,0 +1,3 @@
++#! /bin/sh
++autoreconf -v --install || exit 1
++./configure --enable-maintainer-mode "$@"
+diff -urN xrdb.orig/configure.ac xrdb/configure.ac
+--- xrdb.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ xrdb/configure.ac 2004-08-14 16:03:31.000000000 +0200
+@@ -0,0 +1,41 @@
++dnl
++dnl $Id$
++dnl
++dnl Copyright © 2003 Keith Packard
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this software and its
++dnl documentation for any purpose is hereby granted without fee, provided that
++dnl the above copyright notice appear in all copies and that both that
++dnl copyright notice and this permission notice appear in supporting
++dnl documentation, and that the name of Keith Packard not be used in
++dnl advertising or publicity pertaining to distribution of the software without
++dnl specific, written prior permission. Keith Packard makes no
++dnl representations about the suitability of this software for any purpose. It
++dnl is provided "as is" without express or implied warranty.
++dnl
++dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
++dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
++dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
++dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
++dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
++dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
++dnl PERFORMANCE OF THIS SOFTWARE.
++dnl
++
++AC_PREREQ(2.57)
++AC_INIT([xrdb],4.4.0,[],xrdb)
++AC_CONFIG_SRCDIR([Makefile.am])
++AM_INIT_AUTOMAKE([dist-bzip2])
++AM_MAINTAINER_MODE
++AM_CONFIG_HEADER(config.h)
++
++AC_PROG_CC
++AC_PROG_INSTALL
++AC_PROG_LN_S
++AC_LIBTOOL_WIN32_DLL
++AM_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++PKG_CHECK_MODULES(XRDB, xext xmu x11)
++
++AC_OUTPUT([Makefile])