summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-06-15 17:29:54 -0700
committerChris Larson <clarson@kergoth.com>2010-06-15 14:48:58 -0700
commit1a04610dea376340b9ea4c109f64995b4fd6ad02 (patch)
tree16c1d8fd37b90e8c24172954dcf15f88a6c027da /bin/bitbake
parent1239df8b82ddcd607630da5a888ca83051a22fa8 (diff)
downloadbitbake-contrib-1a04610dea376340b9ea4c109f64995b4fd6ad02.tar.gz
remove return in finally statement
causes exceptions to not be handled after the finally statement Signed-off-by: Cliff Brake <cbrake@bec-systems.com> Signed-off-by: Chris Larson <clarson@kergoth.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake6
1 files changed, 3 insertions, 3 deletions
diff --git a/bin/bitbake b/bin/bitbake
index a6ac45d66..e824ad256 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -195,9 +195,9 @@ Default BBFILES are the .bb files in the current directory.""")
except Exception, e:
print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
raise
- finally:
- serverConnection.terminate()
- return return_value
+
+ serverConnection.terminate()
+ return return_value
if __name__ == "__main__":
ret = main()