summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorJeff Dike <jdike@linux.intel.com>2010-06-29 13:33:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-01 22:32:01 +0100
commit277e8e80c3e1101cdadf234ae74803b9a8d45d25 (patch)
tree753fd9b43c0fde91e21e6e02861e6aac7dd925b7 /bin/bitbake
parent0cd35a24d3e8d0f38b19efa66dd00096008a25af (diff)
downloadbitbake-contrib-277e8e80c3e1101cdadf234ae74803b9a8d45d25.tar.gz
create cooker object after cleaning the environment
Previously, the cooker object was created before the environment was cleaned, saving everything that was in the environment and dumping into the run scripts. The patch ensures that the cooker gets a cleaned environment when it's created. (From Poky rev: 6418d0492a60ed37d13e1060c2e8c09cd127c450) Signed-off-by: Jeff Dike <jdike@linux.intel.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 44725edc8..fdf1e20f8 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -165,13 +165,13 @@ Default BBFILES are the .bb files in the current directory.""")
bb.utils.init_logger(bb.msg, configuration.verbose, configuration.debug,
configuration.debug_domains)
- cooker = bb.cooker.BBCooker(configuration, server)
-
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
# of the UIs (e.g. for DISPLAY, etc.)
bb.utils.clean_environment()
+ cooker = bb.cooker.BBCooker(configuration, server)
+
cooker.parseCommandLine()
serverinfo = server.BitbakeServerInfo(cooker.server)