summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-08-06 16:08:32 -0700
committerChris Larson <chris_larson@mentor.com>2010-08-06 16:30:12 -0700
commit39087138ffd5d427f07ecaa580a40885c5ffaff3 (patch)
tree50496ac071e5455b243347cdb5693be0ede529ea /bin/bitbake
parent499a2d28d578cdd6df7cd30ccb79cc2b2796fb65 (diff)
downloadbitbake-contrib-39087138ffd5d427f07ecaa580a40885c5ffaff3.tar.gz
Drop the 'ui failed to start' message, as the ui_init does more in knotty
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake6
1 files changed, 1 insertions, 5 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 7caa5d95e..846172a48 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -198,11 +198,7 @@ Default BBFILES are the .bb files in the current directory.""")
print("FATAL: Invalid user interface '%s' specified. " % ui)
print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
else:
- try:
- return_value = ui_init(serverConnection.connection, serverConnection.events)
- except Exception as e:
- print("FATAL: Unable to start to '%s' UI: %s" % (ui, e))
- raise
+ return_value = ui_init(serverConnection.connection, serverConnection.events)
finally:
serverConnection.terminate()